Creating Personalized Envelopes in Open Office Writer

MAIL MERGE ENVELOPES

Creating personalized envelopes is not a difficult task with Open Office Writer. It consists of four separate steps:

1. Creating the address list (database) in Open Office Calc (spreadsheet software).
2. Formatting the envelope in Writer.

3. Performing the mail merge in Writer.
4

Printing the envelopes.

CREATING THE DATABASE:

In order to create personalized envelopes, a brief introduction to databases is necessary. During the mail merge
you are required to link the envelope to an address list, understanding the process is helpful.

A database is a file containing the information being printed. It consists of columns (vertical alignment) and rows
(horizontal alignment) of information. Each column contains one kind of information — name, address, etc.
Information in a column is called a "field". A row of information is called a "record". Each person in an address
list has a record that contains a number of fields. The entire file is called a "table". When the mail merge is being
performed Open Office asks for the table name, its location and the various fields in order to print the envelopes.

The start point is creating the database, Open Open Office Calc the spreadsheet software. A Calc worksheet
consists of rows labeled 1, 2, 3, etc., and columns identified A, B, C, etc. A database can be produced in a
spreadsheet by identifying fields and adding the data.

1 First some house cleaning. Please notice (lower left corner) Calc has opened three "sheets" or
pages in the current document. Only one sheet is required. Using the mouse, right click on
Sheet 2, a popup menu appears.

2 The popup asks if you want to permanently delete the page, left click on the <Yes> button.
Repeat the procedure to delete Sheet 3. This will avoid confusion later when you have to
specify a table. With one worksheet, there can only be one table.

3 The database must identify the fields with

"field headings". Field headings describe |Fle Edit View Dnsert Format Tools Data Window Help

information located in each column. B-2Ha2 BSES% %& Y- - | AMIR

In row 1, column A type FirstName, in b | Default = | Sl HBIU

row 1, column B type LastName, in row %+
1, column C type Address, in row 1, fn 3 |
A B

column D, type CityProv, in row 1, | | ¢ | p [ e [

column E. type Peode. |1 | FirstName LastName Address CityProy Pcode

The field headings in the spreadsheet ER
should look like this. S

4 Complete the address list by filling in the names, addresses, etc., of people you wish to mail
to. At this time a decision has to be made about punctuation. Information can be entered as:
Jones or Jones,
with a comma at the end of a line, or the comma can also be added later. The method used is
not critical, however, it must be consistent. For this exercise do not add punctuation. For
example, enter information in each field as: Mary Brown 123 Down The Lane Kitchener ON
A1B 2C3. Punctuation will be added during envelope formatting. When all the entries are
complete the file must be saved.
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Open File > Save As..., a
popup box opens. Complete
the box as shown, left click
on the <Save> button to save
AddressList in native format
(.ods). Please note, the file
extension (.ods) is
automatically entered due to

File name: Iﬁa:ldressljst j Save |
Save astype: |ODF Spreadshest (ods) <] cancd |

v Automatic file name extension
[~ Save with password

[~ | Edit filter setitgs A

the check in the extension

box. The spreadsheet file — AddressList.ods should be saved to the default directory (My
Documents). When the file has been saved, close Calc.

ForMATTING THE ENVELOPE:

The second part of the process is to link the database to the word processing software and create the format for the
envelope addresses.

6

Open Open Office Writer, open

Wizards » Address Data Source... a

File »

" Qutlook address book
" Windows system address book

popup box opens. This box is the first step @ Other external data source

in linking the database to the software,
eventually leading to the mail merge.

Select Other external data source and Help << Back Next >> Finish

left click <Next>>.

When the next popup box opens,

The next box requires the
database type to be specified —
dbase, Address Book, or
Spreadsheet, etc. Use the down
arrow and select Spreadsheet.
Left click <Next>>.

10 This popup requires a path to

the file, left click <Browse>,
AddressList should be located in
My Documents on your
computer. Your path will be
different than the illustration.
When the file is found in the
new popup box, left click
<Open>. Then Left click <Test
Connection>, if successful

left click <Settings>.

Database type

On the following pages, you can make detailed settings for the connection.

Database properties - Connection settings il

General

Path to the spreadsheet document

| C:\Users\Elmer\Documents\AddressList.ods

User authentication

[” Password required

Open Office will tell you everything is alright. Left click <OK>, then left click <Finish>.

11 A new popup box opens. This is where Field Assignments are made or how the address block
is related to the database. Left click <Field Assignment>.
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12 The Address Data — Field
Assignment box is where field
headings from AddressList are
linked to the default headings in
Open Office Writer. Please note, the
listing is far more extensive than
AddressList. In the future more
fields and information could be
added. Make changes to your popup
box so it reads as illustrated.

When everything is correct, left
click <OK>. The Address Data box

closes and the Address Book Wizard

is still visible, left click <Finish>.

This completes the integration of the
data to the software. The next step is to

format the envelope.

13 Open Insert > Envelope... a popup
box opens where the address blocks are
set up and the envelope is formatted.

Notice the linkage to the database

"Addresses", the table "Sheetl" and the
Database field "FIRSTNAME". Use the
down arrow in the Database field line to

Address Data - Field Assignment

x|

scroll down to locate the appropriate
data. Select the data and then left click
the left arrow €=to send the data into

the Addressee block.

14 Complete the Addressee block until it looks like the example below. Please note,
<Addresses.Sheet1.0.FIRSTNAME> is the complete path to the data in the database. It is

followed by

<Addresses.Sheetl.0.LASTNAME>.

This is not clearly visible in the
example.

15 Complete the Sender information with

your name, address, etc., as in the
example. Disregard the highlighted

sender information, this will not happen
when you do it. To advance to the next

line just press the <Enter> key as in
normal typing.

Address Book Source
Data source |Addresses j|
Table | Sheeti| j|
Field assignment
First name FIRSTNAME ~| Last name LASTNAME | i’
Street ADDRESS ~| ZIP code pcODE 7|
City CITYPROWV j State <none> j
Country <none> j Tel: Home <nones j ;l
oK I Cancel | Help |
o ]
EnvelopelFormatl Printer |
Addressee Database
<pAddresses.Sheetl.0.FIRSTNAME=> = |Addresses j|
Table
[sheet1 =
= Database field
q I»] 4 | [FRsTNAME =l
Iv Sender
d L
MNew Doc. Insert | Cancel | Help | Reset
]
EnvelopeIFormatI Prlnterl
Addressee Database
<Addresses.Sheetl.0.FIRSTNAME> <Addres = | ‘Addresses j|
<Addresses.Sheetl.0.ADDRESS >
<Addresses.Sheetl.0.CITYPROV> Table
<Addresses.Sheetl.0.PCODE> ‘Sheetl j|
= Database field
. | o] || =l
¥ sSender
Postal Codel
1 I
New Doc Insert | Cancel | Help | Reset

16 If everything is acceptable, left click the Format tab. It is the middle tab in the top left line —
Envelope Format Printer. A new popup box opens where you specify envelope parameters.
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17 The top two areas allow you to specify

the location of the blocks for the (veope

Addressee and the Sender. You can Envelope Format | Printer |

measure the distance left and down for Addressee

each, however, there is an easier way e

illustrated later. For this exercise, the tomlel 250" =] beonat e
envelope you will use is not a standard from top 0

envelope, but measures 5 inches wide by Sender
4 inches high. Left click the down arrow Fositon
for the Format box, scroll down to select
User Defined. While scrolling through the s
listing, notice the standard letter sizes Size

A

from |eft 3 Format Edit -

available. After selecting User Defined, Farmat Leer Define
type 5'"' in the Width box and 4" in the Width 0
height box as shown. Height 400" 3

18 The next step is important. At this point,

the envelope size and address block NewDoc. | Insert | cancel | o Help | Reset

locations have been specified. However,
the document definition is still the default 8.5"x11" letter sized document. To get the correct
envelope, left click <New Doc.>. This creates a new working document for the envelope size
specified (5"x4") with the address blocks embedded.

19 A representation of the new document appears. =
Notice the addressee block is too small for the Your Name,
<FIRSTNAME> <LASTNAME> combination. The| {8

location of the text block can also be improved. To Postal Code

fix the problem, move the cursor directly onto one

of the lines of the addressee block, left click on the

line. Yellow squares appear, they are handles s s e
<FIRSTNAME><LASTNAM

allowing you to resize the block. Move the cursor E>

into the addressee block, the cursor turns into a four o ADIDIEE 1
. . . <CITYPROV>

headed arrow indicating you can move the block, <PCODE> I

left click and drag the block up and to the left to a
better location.

20 Left click on the yellow handle located in the
middle of the right side, the cursor turns into a two

headed arrow indicating you can stretch the side of
the block left or right, stretch the block to the right. Your Name,

Your Address,

Make the block large enough for <FIRSTNAME> Your City, Province,

<LASTNAME> to fit on one line. Posal Code
21 Time to format the text and add punctuation to the
addressee block. In the example, a space has been CFIRSTNAME> <LASTNAME>.
added between <FIRSTNAME> <LASTNAME>, <ADDRESS>,
commas have been added at the end of the first, ig&gg)ow,

second and third lines. The font (text style) and size
remain at the default — Times Roman 12 point. The
sender block has punctuation added and the font has
been changed to different font and 10.5 point.

The envelope is now ready for the mail merge. The

file can be "Saved As..." at this point to create a

Page 4



Creating Personalized Envelopes in Open Office Writer

template. The template can be used with any address list if the field headings are the same. For
this exercise we will leave everything as is and go to the next step.

ADDING ADDRESSES WITH MAIL. MERGE

22 Still in Open Office, open Tools » Mail
Merge Wizard... A popup box opens
displaying the steps that have to be taken
(on left). The first step is to select the

working document, this is the envelope you

just finished formatting. Use the current
document should be selected, left click
<Next>>.

Select starting document for the mail merge

Select the document upon which to base the mail merge document

# |se the current document

" Create a new document

23 Step 2 — Select Document Type should be Letter, left click <Next>>.

24 Step 3 — Insert Address Block can be ignored, it is already complete, left click <Next>>.

25 Step 4 — Create salutation can be ignored, left click <Next>>.

26 Step 5 — Edit document is a final opportunity to edit the envelopes before they are saved or
printed. Please note the final paragraph, it states a small window will be available to return to
the Wizard. When you have finished reading the paragraph, left click <Edit Document...>.

27 The first envelope with address should be

visible. If everything is OK, left click the Return

to Mail Merge Wizard in the upper left corner.

28 Step 6 — Adjust layout is not available.

29 The next step, Step 7, performs the mail merge.

Left click 7 — Personalize document. Notice the

popup box indicating the envelopes are being

processed.

30 Left click <Edit individual document...>

You are immediately placed in document 1 of the

number of envelopes in your address list. Scroll
through the pages and see if everything is as
anticipated. When everything is correct, left
click <Return to Mail Merge Wizard>, then left click <Next>>.

PRINTING OR SAVING THE DOCUMENT

Your Name,

Your Address,

Your City, Province,
Postal Code

Roger & June Bravo,
RR.#5,

Eganville, ON,

KO0J 1TO

The final step is to save or print the envelopes. For this exercise, the | Save print or send the document
envelopes will be saved rather than printed. the Mail Merge Wizard | cuect ane of the options below:

should be at Step 8 — Save, Print or Send.

" Save starting document
* Save merged document

" Print merged document

31 In the upper portion, Select one of the options below: R

select Save merged document. This is a document that | Save merged document

contains all the envelopes in the Address List.
In the lower portion, Saved merged document section , (" Save as individual documents

select Save as single document. Each address/envelope Ceom [1 | o
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is saved as a page in a large document.

If Save as individual documents is selected, each address/envelope is a separate small file.
This is a handy if you send letters to the same people often. It allows you to print a single

envelope at a time.
Left click <Save Documents>.

32 The Save As popup box appears asking
for a filename and location to save the
file. Save the file as
AddressedEnvelopes, ensure the type is
ODF Text Document (.odt), and save it
in the default directory — Documents.
Left click <Save>.

33 The mail Merge Wizard box reappears,
left click <Finish>. It appears that the
AddressedEnvelopes file has not been
saved, however it has. You can safely
Exit the software and Discard the
changes.

The file AddressedEnvelopes.odt can be opened at
any time and used to print envelopes. All the
addresses in the address list will be printed. If you
anticipate printing individual envelopes, use Save as
individual documents as described in step 31.

B X|
Save in: Iﬁ Documents j = £ E-
E Name = I'I Date md'rﬁedlvl Type I'I Size |'| | L=
Fiicint Phain | b C.omputer Club
| File Folder
I
; Excel Files
[Z \ File Folder
Florida
I File Folder
| Hal
\ File Folder
a8
vy
File Folder
Jason
W File Folder LI
File name: IAddressedEn\relopes j Save
Save astype: (ODF Text Document (odt)
¥ Automatic file name extension
4

Page 6



